Elevated HTTP 500 Errors for Quota API

Incident Report for Twilio

Resolved

Elevated rate of HTTP 500 errors for Quota API issue has been resolved and Flex is operating normally at this time.
Posted May 03, 2025 - 13:03 PDT

Monitoring

We are observing recovery in the Quota API requests affecting billing for Flex customers. We will continue to monitor system stability and provide another update in 1 hour or as soon as more information becomes available.
Posted May 03, 2025 - 11:58 PDT

Update

We continue investigating an elevated rate of HTTP 500 errors for Quota API requests which affects billing for flex customers. Our engineers are working on the issue, and we will provide another update in 4 hours or as soon as more information becomes available.
Posted May 03, 2025 - 08:45 PDT

Update

We continue investigating an elevated rate of HTTP 500 errors for Quota API requests which affects billing for flex customers. Our engineers are working on the issue, and we will provide another update in 2 hours or as soon as more information becomes available.
Posted May 03, 2025 - 06:50 PDT

Investigating

We are currently investigating an elevated rate of HTTP 500 errors for Quota API requests which affects billing for flex customers. Our engineers are working on the issue, and we will provide another update in 1 hour or as soon as more information becomes available.
Posted May 03, 2025 - 05:49 PDT
This incident affected: FLEX (Flex Application Platform, Flex Billing) and DEVELOPER TOOLS (REST API).