A2P 10DLC Campaign Statuses Remaining 'In Review'

Incident Report for Twilio

Resolved

The issue impacting campaign review statuses has been resolved and A2P 10DLC campaign status is operating normally at this time.
Posted Sep 18, 2026 - 17:06 PDT

Monitoring

We have implemented a fix and A2P 10DLC campaign statuses are now operating normally. We will continue to monitor for system stability. We'll provide another update in 30 minutes or as soon as more information becomes available.
Posted Sep 18, 2026 - 16:36 PDT

Update

We are investigating an issue with A2P 10DLC campaign statuses. At this time A2P 10DLC status may remain stuck in the 'In Review' status longer than normal. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Sep 18, 2026 - 15:30 PDT

Investigating

We are investigating an issue with A2P 10DLC campaign statuses. At this time A2P 10DLC status may remain stuck in the 'In Review' status longer than normal. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Sep 18, 2026 - 14:34 PDT
This incident affected: TWILIO PLATFORM (Trust Hub).