Slow Response Times and Increased Errors for Lookup API V2

Incident Report for Twilio

Resolved

Twilio Lookup API V2 was degraded for 38 minutes between 3:35pm and 4:13pm Pacific Time on 06/17/2025. During this period of time customers may have experienced slow API response times and increased errors. The issue has now been resolved.
Posted Jun 18, 2025 - 00:15 PDT

Update

Twilio Lookup API V2 was degraded for 38 minutes between 3:35pm and 4:13pm Pacific Time on 06/17/2025. During this period of time customers may have experienced slow API response times and increased errors. The issue has now been resolved.
Posted Jun 17, 2025 - 17:17 PDT

Investigating

Our monitoring systems have detected a potential issue with Lookup API v2. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Jun 17, 2025 - 16:18 PDT