Elevated 500 Errors on Multiple Twilio APIs

Incident Report for Twilio

Update

We are no longer seeing an increase in API failures on multiple Twilio APIs. This incident has been resolved.
Posted Aug 04, 2026 - 10:02 PDT

Investigating

As of 16:13 UTC, we're seeing an increase in API failures on multiple Twilio APIs. The failures have tapered down to pre-event levels at 16:20 UTC. We're still monitoring our services and finding the root cause for the elevated failures.

We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Aug 04, 2026 - 09:45 PDT
This incident affects: PROGRAMMABLE MESSAGING (Programmable Messaging API).