Delays with Inbound and Outbound Message Delivery for RCS and WhatsApp

Incident Report for Twilio

Resolved

We are no longer experiencing delays with inbound and outbound message delivery for RCS and WhatsApp. This incident has been resolved.
Posted Jul 31, 2026 - 10:14 PDT

Monitoring

We are observing recovery in delays with inbound and outbound message delivery for RCS and WhatsApp. We will continue monitoring the service to ensure a full recovery. We will provide another update in 30 minutes or as soon as more information becomes available.
Posted Jul 31, 2026 - 09:44 PDT

Update

We are still seeing delays with inbound and outbound message delivery for RCS and WhatsApp. Our team is actively investigating the issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Jul 31, 2026 - 09:35 PDT

Investigating

We are currently experiencing delays with inbound and outbound message delivery for RCS and WhatsApp. Our team is actively investigating the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jul 31, 2026 - 08:35 PDT
This incident affected: PROGRAMMABLE MESSAGING (WhatsApp Messaging, RCS Messaging).