Our Engineers are Investigating an Issue with 10dlc and TF Compliance impacted during the AWS DynamoDB outage on Dec 3rd

Incident Report for Twilio

Resolved

This incident has been resolved.
Posted Dec 09, 2025 - 16:25 PST

Monitoring

Our engineers are currently investigating the customer impact of a retroactive issue with 10dlc and TF Compliance impacted during the AWS DynamoDB outage on Dec 3rd. We will follow up and provide customer impact details within 2 hours.
Posted Dec 09, 2025 - 15:56 PST