MMS Delivery Delays to Multiple Networks in the US from a Small Subset of Short Codes

Incident Report for Twilio

Update

We continue experiencing MMS delivery delays to multiple networks in the US from a small subset of short codes. Our engineers are working to resolve the issue. We will provide another update in 16 hours or as soon as more information becomes available.
Posted Sep 11, 2025 - 02:48 PDT

Update

We continue experiencing MMS delivery delays to multiple networks in the US from a small subset of short codes. Our engineers are working to resolve the issue. We will provide another update in 8 hours or as soon as more information becomes available.
Posted Sep 10, 2025 - 18:49 PDT

Update

We continue experiencing MMS delivery delays to multiple networks in the US from a small subset of short codes. Our engineers are working to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
Posted Sep 10, 2025 - 14:54 PDT

Update

We continue experiencing MMS delivery delays to multiple networks in the US from a small subset of short codes. Our engineers are working to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Sep 10, 2025 - 12:54 PDT

Investigating

We are experiencing MMS delivery delays to multiple networks in the US from a small subset of short codes. Our engineers are working to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Sep 10, 2025 - 11:54 PDT
This incident affects: CARRIER NETWORK (MMS Short Code, North America).