Increase in 5XX Errors Within Studio Workflow Engine

Incident Report for Twilio

Resolved

The 5xx errors have been resolved, and the Studio workflow engine is operating normally at this time.
Posted Dec 10, 2025 - 00:15 PST

Monitoring

We have mitigated the issue impacting our Studio workflow engine, which experienced 5xx errors. Our teams are actively monitoring the situation for any further customer impact. We will provide an update within the 2 hours.
Posted Dec 09, 2025 - 22:15 PST

Update

We are continuing to investigate this issue.
Posted Dec 09, 2025 - 22:04 PST

Investigating

We are currently investigating an increase in 5XX errors within our Studio workflow engine. As a result, some customers may experience the following issues, such as Calls may not answer or may hang up unexpectedly and/or inbound messages may not be processed. Our engineering teams are actively working to resolve the issue, and will have an update within 1 hour.
Posted Dec 09, 2025 - 21:30 PST
This incident affected: SERVERLESS (Studio).