Customers Are Experiencing Significant Service Disruption in Alarm Notifications on Console

Incident Report for Twilio

Resolved

Twilio Alarms Console notification was degraded for 3 hours 30 minutes between 05:45 and 09:15 Pacific Time on 05/06/2025. During this period of time customers may have experienced missing console notification for alarms.
Posted May 06, 2025 - 09:33 PDT

Investigating

Our monitoring systems have detected a potential issue with rate limits. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted May 06, 2025 - 09:24 PDT