SMS Delivery Delays and Failures between a Subset of Twilio Short Codes and Multiple Networks in Ireland

Incident Report for Twilio

Resolved

We have completed our investigation and determined that this event did  result in a subset of  customer's  impact. We have contacted impacted customers to provide additional information about the incident.
Posted Jun 04, 2026 - 13:45 PDT

Investigating

Twilio customers may be experiencing SMS delivery failures between a subset of Twilio Short Codes and network subscribers on multiple networks in Ireland. Our team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jun 04, 2026 - 13:19 PDT
This incident affected: CARRIER NETWORK (SMS, Europe).