Unable to save Phone Numbers with Studio Flow

Incident Report for Twilio

Resolved

The incident has been resolved and saving phone number configurations assigned to a Studio Flow are operating normally.
Posted Jul 29, 2026 - 00:55 PDT

Update

We are still investigating a service interruption with Console when saving phone number configurations assigned to a Studio Flow. As a temporary workaround, please ensure a valid Status Callback URL is populated when setting your Voice URL to a Studio Flow. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Jul 29, 2026 - 00:37 PDT

Investigating

We are investigating a service interruption with Console when saving phone number configurations assigned to a Studio Flow. As a temporary workaround, please ensure a valid Status Callback URL is populated when setting your Voice URL to a Studio Flow. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Jul 28, 2026 - 23:42 PDT
This incident affected: SERVERLESS (Studio).