We are observing recovery in SMS delivery delays when sending messages from a subset of Twilio Short Codes to multiple networks in the United States of America. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Mar 07, 2026 - 12:41 PST
Update
Twilio customers may continue to experience SMS delivery delays and SMS delivery receipt delays from a subset of Twilio Short Codes to multiple networks in the United States of America. Our team is actively investigating this issue. Message delivery may succeed, but delivery receipts may be delayed. We will provide another update in 8 hours or as soon as more information becomes available.
Posted Mar 07, 2026 - 10:25 PST
Update
Twilio customers may continue to experience SMS delivery delays and SMS delivery receipt delays from a subset of Twilio Short Codes to ISP Telecom network subscribers in the United States. Our team is actively investigating this issue. Message delivery may succeed, but delivery receipts may be delayed. We will provide another update in 4 hours or as soon as more information becomes available.
Posted Mar 07, 2026 - 06:27 PST
Update
Twilio customers may continue to experience SMS delivery delays and SMS delivery receipt delays from a subset of Twilio Short Codes to ISP Telecom network subscribers in the United States. Our team is actively investigating this issue. Message delivery may succeed, but delivery receipts may be delayed. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Mar 07, 2026 - 04:29 PST
Investigating
Twilio customers may be experiencing SMS delivery delays and SMS delivery receipt delays from a subset of Twilio Short Codes to ISP Telecom network subscribers in the United States. Our team is actively investigating this issue. Message delivery may succeed, but delivery receipts may be delayed. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 07, 2026 - 03:25 PST
This incident affects: CARRIER NETWORK (SMS Short Code, North America).