Whatsapp Customers Are Unable to Onboard New Senders While Using Twilio Console

Incident Report for Twilio

Resolved

The issue where some WhatsApp customers are unable to onboard new senders with their preferred display name through the Twilio Console is ongoing. As a workaround, customers can use the Senders API, or continue using the Twilio Console for registration without a preferred display name. We will continue to work with our provider to fully resolve this issue.
Posted Dec 10, 2025 - 14:18 PST

Update

We are currently investigating an issue where some WhatsApp customers are unable to onboard new senders with their preferred display name through the Twilio Console. As a temporary workaround, customers can use the Senders API or continue using the Twilio Console for registration without a preferred display name. Our engineering teams are actively working to resolve the issue, and will have an update within 16 hours.
Posted Dec 10, 2025 - 03:15 PST

Update

We are currently investigating an issue where some WhatsApp customers are unable to onboard new senders with their preferred display name through the Twilio Console. As a temporary workaround, customers can use the Senders API or continue using the Twilio Console for registration without a preferred display name. Our engineering teams are actively working to resolve the issue, and will have an update within 8 hours.
Posted Dec 09, 2025 - 18:53 PST

Update

We are currently investigating an issue where some WhatsApp customers are unable to onboard new senders with their preferred display name through the Twilio Console. As a temporary workaround, customers can use the Senders API or continue using the Twilio Console for registration without a preferred display name. Our engineering teams are actively working to resolve the issue, and will have an update within 4 hours.
Posted Dec 09, 2025 - 14:52 PST

Update

We are currently investigating an issue where some WhatsApp customers are unable to onboard new senders with their preferred display name through the Twilio Console. As a temporary workaround, customers can use the Senders API or continue using the Twilio Console for registration without a preferred display name. Our engineering teams are actively working to resolve the issue, and will have an update within 2 hours.
Posted Dec 09, 2025 - 12:41 PST

Identified

Whatsapp customers are unable to onboard new senders while using Twilio Console Self sign up flow. We are investigating the issue and will have an update within 1 hour.
Posted Dec 09, 2025 - 11:43 PST
This incident affected: PROGRAMMABLE MESSAGING (Messaging Channels).