Delay in Message Redactions

Incident Report for Twilio

Resolved

We have fully investigated the Bulk Export API issue triggered by our automated alert, and it was determined that there is no noticeable customer impact. All systems are operational.
Posted Jul 30, 2026 - 11:54 PDT

Update

We are contiuning to investigate this issue.
Posted Jul 30, 2026 - 11:28 PDT

Update

We are continuing to investigate this issue.
Posted Jul 30, 2026 - 09:25 PDT

Update

We are contiuning to investigate this issue.
Posted Jul 30, 2026 - 09:19 PDT

Investigating

We are currently investigating an issue with stuck events regarding Bulk Export API. We expect to provide another update in 1 hour or as soon as more information becomes available
Posted Jul 30, 2026 - 07:41 PDT