MMS Delivery Delays and Failures from a Subset of Twilio Short Codes to Multiple Networks in United States

Incident Report for Twilio

Update

Twilio customers may be experiencing MMS delivery delays and failures from a subset of Twilio Short Codes to network subscribers on multiple networks in the United States. Our team is actively investigating this issue. We will provide another update in 4 hours or as soon as more information becomes available.
Posted Sep 07, 2026 - 02:01 PDT

Update

Twilio customers may be experiencing MMS delivery delays and failures from a subset of Twilio Short Codes to network subscribers on multiple networks in the United States. Our team is actively investigating this issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Sep 07, 2026 - 00:00 PDT

Investigating

Twilio customers may be experiencing MMS delivery delays and failures from a subset of Twilio Short Codes to network subscribers on multiple networks in the United States. Our team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Sep 06, 2026 - 22:55 PDT
This incident affects: CARRIER NETWORK (MMS Short Code, North America).