Automated Alert: Minimal Customer Impact
Incident Report for Twilio
Resolved
We have fully investigated the identity issue, and it was determined that the impact was limited to a small set of customers, who have been contacted individually to address any concerns. All systems are operational.
Posted Sep 12, 2024 - 12:00 PDT
Investigating
Our monitoring systems have detected a potential issue with Identity. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Sep 12, 2024 - 11:40 PDT