Missing or Delayed Alert Notifications for Messaging Traffic Anomalies

Incident Report for Twilio

Resolved

The issue affecting Intelligent Alerts has been resolved. Alert notifications have fully resumed. We apologize for any disruption.
Posted Aug 25, 2026 - 09:36 PDT

Monitoring

Alert notifications for Intelligent Alerts are being restored. We are monitoring to confirm full recovery and will provide another update in 30 minutes or once we have additional information.
Posted Aug 25, 2026 - 09:05 PDT

Investigating

We have identified an issue affecting Intelligent Alerts. Alert notifications for messaging metric anomalies may be delayed or missing while our team works on a fix. We will provide another update in in 1 hour or as soon as more information is available.
Posted Aug 25, 2026 - 08:45 PDT
This incident affected: PROGRAMMABLE MESSAGING (Intelligent Alerts).