Customer data on the link shortening tab assumes 0 record updates in the last 2 hours

Incident Report for Twilio

Resolved

This incident has now been resolved.
Posted Jun 20, 2025 - 23:40 PDT

Monitoring

We’re seeing recovery and monitoring an incident that may have affected the Link Shortening tab within Messaging Insights.
We will provide you with an update within the next 30mins or as soon as more information becomes available.
Posted Jun 20, 2025 - 23:04 PDT

Update

We’re continue to investigate an incident that may affect the Link Shortening tab within Messaging Insights. Customers may notice undercounted records for the time period starting from June 20, 2025, at 23:20 UTC to the present (ongoing). This issue only impacts those who are viewing data with a time range greater than two days. We will provide you an update within the next 4 hours or as soon as more information becomes available.
Posted Jun 20, 2025 - 21:19 PDT

Update

We’re continue to investigate an incident that may affect the Link Shortening tab within Messaging Insights. Customers may notice undercounted records for the time period starting from June 20, 2025, at 23:20 UTC to the present (ongoing). This issue only impacts those who are viewing data with a time range greater than two days. We will provide you an update within the next 2 hours or as soon as more information becomes available.
Posted Jun 20, 2025 - 19:31 PDT

Investigating

We’re currently investigating an incident that may affect the Link Shortening tab within Messaging Insights. Customers may notice undercounted records for the time period starting from June 20, 2025, at 23:20 UTC to the present (ongoing). This issue only impacts those who are viewing data with a time range greater than two days.

We will provide you an update within the next 1 hour or as soon as more information becomes available.
Posted Jun 20, 2025 - 18:44 PDT
This incident affected: PROGRAMMABLE MESSAGING (Messaging Insights).