Issue With Help Center When Switching to Subaccounts and Viewing Ticket History

Incident Report for Twilio

Resolved

Help Center issue has been resolved and it is operating normally at this time.
Posted Oct 27, 2025 - 10:35 PDT

Monitoring

Help Center is now operating normally. We will continue to monitor for system stability. We'll provide another update in 30 minutes or as soon as more information becomes available.
Posted Oct 27, 2025 - 10:02 PDT

Update

We are investigating an issue with Help Center when switching to subaccounts and viewing ticket history. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Oct 27, 2025 - 09:16 PDT

Investigating

Our monitoring systems have detected a potential issue with the Console when switching to subaccounts and viewing ticket history. Our engineering team has been alerted and is actively investigating. We will provide updates as soon as more information becomes available.
Posted Oct 27, 2025 - 08:55 PDT
This incident affected: TWILIO PLATFORM (Customer Support Center).