Twilio Transcript for Voice and Video degraded

Incident Report for Twilio

Resolved

Twilio Transcript was degraded for 38 minutes between 8:55 to 9:33 am PDT 7/28/2026. During this period of time customers may have experienced degraded speech recognition and realtime transcriptions for Voice and Video.. The issue has now been resolved.
Posted Jul 28, 2026 - 09:46 PDT

Investigating

Our monitoring systems have detected a potential issue with transcription. Our engineers have been alerted and are investigating. We will provide an update when we have more details.
Posted Jul 28, 2026 - 09:32 PDT