Elevated HTTP 500 Errors for Twilio Programmable Messaging API – June 18, 2025

Incident Report for Twilio

Resolved

The Twilio Programmable Messaging API was partially degraded for 1 minute on June 18th, 2025, between 18:03 PST and 18:04 PST. During this period of time, customers sending a message may have received elevated volumes of 5xx's in API responses. This issue has now been resolved.
Posted Jun 18, 2025 - 18:55 PDT

Investigating

The Twilio Programmable Messaging API was partially degraded for 1 minute on June 18th, 2025 between 18:03 PST and 18:04 PST. During this period of time, customers sending a message may have received elevated volumes of 5xx's in API responses. This issue has now been resolved.
Posted Jun 18, 2025 - 18:52 PDT
This incident affected: PROGRAMMABLE MESSAGING (SMS).