The issue affecting S/S, CNAM, and Voice Integrity for phone numbers on sub-accounts has been successfully resolved. We have monitored the systems and confirmed that all services have returned to normal operation. We apologize for any inconvenience this may have caused and appreciate your patience.
Posted Aug 31, 2026 - 19:43 PDT
Update
After monitoring for some time, we started seeing a degradation of the service. Some phone numbers on sub-accounts might witness degraded experience on S/S, CNAM and Voice Integrity. Our engineers are working to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted Aug 31, 2026 - 16:28 PDT
Update
After monitoring for some time, we started seeing a degradation of the service. Some phone numbers on sub-accounts might witness degraded experience on S/S, CNAM and Voice Integrity. Our engineers are working to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Aug 31, 2026 - 14:28 PDT
Identified
After monitoring for some time, we started seeing a degradation of the service. Some phone numbers on sub-accounts might witness degraded experience on S/S, CNAM and Voice Integrity. Our engineers are working to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Aug 31, 2026 - 13:28 PDT
Update
We are continuing to investigate this issue.
Posted Aug 31, 2026 - 13:28 PDT
Investigating
Our monitoring systems have detected a potential issue. Our engineers have been alerted and are investigating. We will provide an update when we have more details.